[OPERATIONAL ANNOUNCEMENT] Polaris Maintenance Update – May 14, 2025

Incident Report for Polaris Status

Resolved

The planned maintenance period for Wednesday May 14, 2025 from 8 PM ET and 9 PM ET is now completed.
Posted May 14, 2025 - 22:02 EDT

Investigating

[OPERATIONAL ANNOUNCEMENT] The planned maintenance period for Wednesday May 14, 2025 from 8 PM ET and 9 PM ET is taking longer than expected in the production environment only (the maintenance has been completed in Production EU and POC). If you are unable to login, please wait a few minutes before trying again. We will provide updates every 30 minutes until this maintenance is completed.
Posted May 14, 2025 - 21:36 EDT
This incident affected: Authentication, Issue Management, Dashboards and Reporting, UI Services, and API services.